Can't access Telecentro router anymore

  • I have downloaded an app called Printer Pro by Readdle as part of a bundle that should allow me to print from my mobile to my wireless printer directly (it is not an AirPrint-enabled printer) however it works if the printer has a static IP. I know how to do it, but oddly I cannot access Telecentro router.



    I can access the printer's webpage and there I can find its IP (192.168.1.67). I set the boot method to STATIC.

    However, I'd really like that the static IP was set in the router rather than in the printer (I am afraid the printer could lose the settings in case I disconnect it).


    I type 192.168.1.1 to access Telecentro's router and set to assign the same static IP to the printer (based on its Mac), but I keep getting a timeout error. I have tried with Safari and with Chrome (ERR_CONNECTION_TIMED_OUT). Last night I could access the router login page, but then I couldn't enter the router as the connection closed.

    I have tried both connecting to the WiFi 5G network and the regular network (where my printer is).


    I have no internet navigation issue.

  • It turned out I had to check 192.168.0.1 and it worked after a few attempt. I was able to set a static IP for the printer. Let's see if I should remove the static boot setting from the printer, or if it works anyway. What's your thought? What would be neater?

  • Yes, it has. However, it is disabled automatically after two minutes (as per router settings I can't change).

    But I believe my printer has not.


    Anyway, I have be poking around too much and the printer is behaving erratically. Since it is still under warranty, tomorrow I'll bring it to the support service which is just 10 blocks away. They've already replaced the drum a few months ago...